Identification des actes CSARR codés plusieurs fois dans une même journée à tort

Contexte : voir l’article Codage d’un même acte CSARR au plus 1 à 4 fois par jour

Cet article décrit, étape par étape, la procédure dans T2A VIEWER SSR puis dans Excel pour identifier les actes CSARR codés à tort en surnombre sur une même journée en distinguant les différentes situations :
# actes CSARR hors séance
# actes CSARR de séance, dont le cas des actes CSARR autorisant le modulateur QM

Cette procédure correspondant à la fonctionnalité 57 de T2A VIEWER.

Cas des actes CSARR hors séance
1 – écran « Base des actes CSARR » et sélection des actes CSARR avec le type d’actes = « Actes hors séance »
Exporter les résultats sur excel

2 – Dans l’excel, insérer une nouvelle colonne qui concatène les 4 colonnes « Acte CSARR », « NAS », « Intervenant » et « Date de réalisation ». Formule à étendre sur toutes les lignes.
Exemple : =A2&C2&F2&I2
Discussion : le fait de prendre en compte la colonne « Intervenant » dans la concaténation permet d’éliminer tout faux positif mais du coup laisse passer des faux négatifs. Il peut alors être intéressant de ne concaténer que les 3 colonnes « Acte CSARR », « NAS » et « Date de réalisation » pour repérer aussi de possible doublons d’actes CSARR hors séances sur une même journée codés par des types d’intervenants différents (généralement au plus 2). A arbitrer en fonction de vos ressources et priorités.

3 – Rajouter une nouvelle colonne qui va calculer le nombre d’occurences de chaque ligne de la colonne insérée à l’étape 2
Formule = NB.SI($J$2:$J$1000;J2) où J = la colonne insérée à l’étape 2 et 1000 = la ligne maximale de la colonne J
Formule à étendre sur toutes les lignes puis filtrer cette colonne pour les valeurs > 1. Les lignes sélectionnées correspondent alors aux actes CSARR recherchées, codées en trop à tort.

Cas des actes CSARR de séance
1 – écran « Base des actes CSARR » et sélection des actes CSARR avec le type d’actes = « Actes de séance »

Exporter les résultats sur excel

2 – Dans l’excel, insérer une nouvelle colonne qui concatène les 4 colonnes « Acte CSARR », « NAS », « Intervenant » et « Date de réalisation ». Formule à étendre sur toutes les lignes.
Exemple : =A2&C2&F2&I2
Discussion : voir la discussion étape 1 du cas des actes CSARR hors séance

3 – Rajouter une nouvelle colonne qui va calculer le nombre d’occurences de chaque ligne de la colonne insérée à l’étape 2
Formule = NB.SI($J$2:$J$1000;J2) où J = la colonne insérée à l’étape 2 et 1000 = la ligne maximale de la colonne J
Formule à étendre sur toutes les lignes

4 – Filtrer la colonne rajoutée à l’étape 3 pour les valeurs > 2 et filtrer la colonne « Mod. Lieu » hors le modulateur QM
Les lignes sélectionnées correspondent alors à des actes CSARR codées en surnombre à tort.
Discussion : il peut y avoir quelques faux positifs liés à des actes CSARR de séance autorisant le modulateur QM sans modulateur QM codé à tort ou à raison.

5 – Filtrer la colonne rajoutée à l’étape 3 pour les valeurs > 4 et filtrer la colonne « Mod. Lieu » avec le modulateur QM
Les lignes sélectionnées correspondent alors à des actes CSARR codées en surnombre à tort sans faux positif.